I know this is going to see pedantic, but I must address this small grudge I have.
Software Developers and programmers often have strong feelings about naming conventions, from all_understores, to CamelCase, so capsCase and ALL_CAPS and whoThe_hellcareany-way.
I am going to address an issue I’ve found in the two varieties of camel case.
When writing a method like getHTML, or getHtml, it usually implies you have a consistent attitude towards acronyms. Either treat them like a word, or treat them like an acronym or .
Yet, for some reason, a fair portion of developers ignore their own convention, or the company wide/ group wide convention for one specific variable name.
Yes, just one. It’s very infuriating.
ID. Identification. In life, we often write ID or Id. Whichever is correct is not the purpose here. But people either treat it as one or the other.
Yet in code, I am not unfamiliar to seeing;
getHTML in the same package as getId, with an internal variable of int ID.
I just want to say; keep it consistent guys. ID should be kept the same as acronyms on your system. The fact it is an abbreviation is beside the point, in common English it’s treated as “ID” and should be treated in the same way as acronyms.
So it’s either getHTML and getID or getHtml and getId, not a combination of either.